Accounting-Request でセットされるアトリビュート

表 1. Accounting-Request でセットされるアトリビュート
アトリビュート Start Stop 値
NAS-IP-Address (RFC2865) ○ ○ 本機のIPアドレス(本機からRADIUSサーバにメッセージを送出する時に使用する本機のIPアドレス)
NAS-Port-Type (RFC2865) ○ ○ 5 = Virtual
NAS-Port (RFC2865) ○ ○ PPP接続の識別番号
Calling-Station-Id (RFC2865) ○ ○ L2TP で Calling-Number が通知された場合に、Calling-Number
Tunnel-Medium-Type (RFC2868) ○ ○ 1 = IPv4 (L2TP の場合、または PPTP の場合に限る)
Tunnel-Client-Endpoint (RFC2868) ○ ○ トンネル対抗のアドレス(L2TP または PPTP の場合に限る)
Tunnel-Server-Endpoint (RFC2868) ○ ○ トンネルを終端した本機のアドレス(L2TP または PPTP の場合に限る)
Tunnel-Assignment-ID (RFC2868) ○ ○ トンネルの識別番号(L2TP または PPTP の場合に限る)
Acct-Tunnel-Connection (RFC2867) ○ ○ コールの識別番号(L2TP または PPTP の場合に限る)
User-Name (RFC2865) ○ ○ PPPユーザ名
Service-Type (RFC2865) ○ ○ 2 = Framed
Framed-Protocol (RFC2865) ○ ○ 1 = PPP
Framed-IP-Address (RFC2865) ○ ○ トンネル対抗に割り当てたIPアドレス
Acct-Status-Type (RFC2866) ○ ○ Start の場合 1 = Start。Stop の場合 2 = Stop
Acct-Delay-Time (RFC2866) ○ ○ Startまたは Stop してからの経過秒数
Acct-Input-Octets (RFC2866) − ○ 入力オクテット数
Acct-Output-Octets (RFC2866) − ○ 出力オクテット数
Acct-Session-Id (RFC2866) ○ ○ セッション識別子 (先頭8文字でブートを識別し、続く8文字でPPP接続を識別)
Acct-Authentic (RFC2866) ○ ○ 1 = RADIUS
Acct-Session-Time (RFC2866) − ○ セッションの時間
Acct-Input-Packets (RFC2866) − ○ 入力パケット数
Acct-Output-Packets (RFC2866) − ○ 出力パケット数
Acct-Terminate-Cause (RFC2866) − ○ 切断理由
Acct-Input-Gigawords (RFC2869) − ○ 入力ギガワード(オクテット数を64bit表現した場合の上位32bit)
Acct-Output-Gigawords (RFC2869) − ○ 出力ギガワード(オクテット数を64bit表現した場合の上位32bit)