SNMP

SNMPエージェント機能およびSNMPトラップ送信機能を提供します。

SNMPエージェント

表 1. IPv4/IPv6対応状況
機能 IPv4 IPv6 備考
SNMPエージェント ○ ○
表 2. デフォルトの動作状態
機能 状態 備考
SNMPエージェント 無効
SNMPプロトコル
SNMP v1, SNMP v2c, SNMP v3
トランスポートプロトコル
UDP
制限(未対応)
  • インフォーム(Inform)
  • RMON
  • 値の書き込み
  • インタフェースのエイリアスアドレス(ifAlias)の取得

サポートするMIB

表 3. Standard MIB
OID OID 概要 RFC MIB 備考
iso(1).org(3).dod(6).internet(1).mgmt(2).mib-2(1) system(1) 機種・連絡先・設置場所・対応している機能等の管理上の情報 RFC1213 MIB-II
interfaces(2) 入出力パケット数、リンク状態等のインタフェース情報 RFC1213 MIB-II
ip(4) IPの統計情報 RFC1213 MIB-II 一部のMIBのみサポート
snmp(11) SNMPのリクエスト数等の情報 RFC1213 MIB-II
host(25) ホストのリソース情報 RFC2790 MIB-II
ifMIB(31) インタフェースの情報 RFC2863 MIB-II
表 4. Enterprise specific MIB
OID OID 概要 備考
iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).iij(770).seilProducts(1) seilSystem(2) システム情報

interface MIBについて

  • インタフェースごとにinterface MIBのifIndexは静的に割り当てられ、動作状態や設定内容によって変化しません。
  • インタフェースにエイリアスアドレスを設定可能ですが、ifAliasは常に空になります。
  • interfaces MIBおよびifMIBの問い合わせには、定期的に取得したキャッシュ情報を応答します。
  • interfaces MIBおよびifMIBは、ge[]インタフェース、ge[]p[]インタフェース、およびコンフィグ設定が存在するインタフェースについて応答します。
表 5. インタフェース名とifTypeの対応
インタフェース名 ifType
bridge[] bridge(209)
ge[] ethernetCsmacd(6)
ge[]p[] ethernetCsmacd(6)
ipsec[] tunnel(131)
l2tp[] tunnel(131)
ppp[] ppp(23)
pppac[] ppp(23)
pppoe[] ppp(23)
rac[] ppp(23)
tunnel[] tunnel(131)
vlan[] l3ipvlan(136)
wlan[] ieee80211(71)

SNMP v3について

  • USMで管理するユーザを8個まで設定できます。
  • securityLevel authPrivのみ接続できます。

SNMPトラップ

表 6. IPv4/IPv6対応状況
機能 IPv4 IPv6 備考
SNMPトラップ ○ ○
表 7. デフォルトの動作状態
機能 状態 備考
SNMPトラップ 無効
SNMPプロトコル
SNMP v1
トランスポートプロトコル
UDP
トラップ送信先
送信先IPアドレスを4個まで設定可能
制限(未対応)
SNMP v2c, SNMP v3によるトラップ送信

送信するSNMPトラップ

表 8. Standard Trap
トラップ 概要 RFC 備考
coldStart 機器が提供するSNMPエージェントが起動した RFC1157
linkDown 機器が提供するインタフェースがリンクダウンした RFC1157
linkUp 機器が提供するインタフェースがリンクアップした RFC1157
authenticationFailure SNMPの認証に失敗した RFC1157
表 9. Enterprise specific Trap
トラップ 概要 備考
overload 過負荷状態に陥った 過負荷状態から復帰後に送信
lanWatchDown 監視対象ホストがダウンした 死活監視設定時
lanWatchUp 監視対象ホストが復帰した 死活監視設定時

SNMP v1トラップの詳細

表 10. 共通の形式
フィールド 値 意味
SNMP Version 0 SNMP v1
Community 文字列 snmp.community キーの設定値
PDU Type 4 Trap v1
enterprise <sysObjectID>
表 11. 機種ごとのsysObjectID
機種 sysObjectID
SA-W1 1.3.6.1.4.1.770.1.1.10.1
SA-W2 1.3.6.1.4.1.770.1.1.11.1
SA-W2L 1.3.6.1.4.1.770.1.1.11.2
agent-address <IPv4address> エージェントアドレス
  • デフォルト値およびIPv6での送信時は0.0.0.0となる
generic-trap generic-trap番号 トラップごとの値
specific-trap spacific-trap番号 トラップごとの値
time-stamp <sysUpTime> 送信時のシステム稼働時間
Variable Bindings OIDとValueのペア トラップごとの付加情報
coldStart
表 12. トラップのPDU
フィールド 値 意味
generic-trap 0 coldStart
specific-trap 0 Generic
linkDown
表 13. トラップのPDU
フィールド 値 意味
generic-trap 2 linkDown
specific-trap 0 Generic
表 14. Variable Bindings
OID value 意味
ifIndex.<ifIndex> ifIndex値
ifAdminStatus.<ifIndex> ifAdminStatus
ifOperStatus.<ifIndex> ifOperStatus
linkUp
表 15. トラップのPDU
フィールド 値 意味
generic-trap 3 linkUp
specific-trap 0 Generic
表 16. Variable Bindings
OID value 意味
ifIndex.<ifIndex> ifIndex値
ifAdminStatus.<ifIndex> ifAdminStatus
ifOperStatus.<ifIndex> ifOperStatus
authenticationFailure
表 17. トラップのPDU
フィールド 値 意味
generic-trap 4 authenticationFailure
specific-trap 0 Generic
overload
表 18. トラップのPDU
フィールド 値 意味
generic-trap 6 EnterpriseSpecific
specific-trap 1 overload
lanWatchUp
表 19. トラップのPDU
フィールド 値 意味
generic-trap 6 EnterpriseSpecific
specific-trap 11 lanWatchUp
表 20. Variable Bindings
OID value 意味
seilLanWatchNodeAddress.<trap-index> <IPaddress> 監視対象ホストのIPアドレス
seilLanWatchNodeStatus.<trap-index> 1 監視対象ホストの状態がup
  • <trap-index> はsnmp.trap.watch.[].trap-indexキーで設定した値
lanWatchDown
表 21. トラップのPDU
フィールド 値 意味
generic-trap 6 EnterpriseSpecific
specific-trap 12 lanWatchDown
表 22. Variable Bindings
OID value 意味
seilLanWatchNodeAddress.<trap-index> <IPaddress> 監視対象ホストのIPアドレス
seilLanWatchNodeStatus.<trap-index> 2 監視対象ホストの状態がdown
  • <trap-index> はsnmp.trap.watch.[].trap-indexキーで設定した値